Add-on Installation Failed
Component
SAP Business One
Symptom
When installing the add-on inside SAP Business One, the following error occurs:
Add-on installation failed because another version is already installed
Cause
This issue occurs when the server name registered in the AddOnsLocalRegistration.sbo file does not match the server name that holds the customer's database and there is a new add-on version available in the SARI table of the Common DB.
Solution
There are two or more files in the local client directory that store information about the add-ons. These files are: AddOnsLocalRegistration.sbo and AddOnsInstall.sbo.
They are XML based and can be opened using Notepad or any other text editor. Before changing those files, make a copy of them. Open the AddOnsLocalRegistration.sbo and AddOnsInstall.sbo files and if you see the Sana Commerce add-on in the list, remove it. Save your changes. Open SAP Business One and try to install the Sana Commerce add-on again.